const regex = /^\/\/.*(*SKIP)(*FAIL)|("[^"]+")/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\\/\\\/.*(*SKIP)(*FAIL)|("[^"]+")', 'gm')
const str = `// eehen nhdhdhd ooe "jjejej" ejeje "keihjen" jehhemm
jejej "jejeooe" kekek "jilnana" jennbeb`;
const subst = `<span class="red">$1</span>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);