$re = '/^\/\/.*(*SKIP)(*FAIL)|("[^"]+")/m';
$str = '// eehen nhdhdhd ooe "jjejej" ejeje "keihjen" jehhemm
jejej "jejeooe" kekek "jilnana" jennbeb';
$subst = "<span class=\"red\">$1</span>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;