import re
regex = re.compile(r"^\/\/.*(*SKIP)(*FAIL)|(\"[^\"]+\")", flags=re.MULTILINE)
test_str = ("// eehen nhdhdhd ooe \"jjejej\" ejeje \"keihjen\" jehhemm\n"
"jejej \"jejeooe\" kekek \"jilnana\" jennbeb")
subst = "<span class=\"red\">$1</span>"
result = regex.sub(subst, test_str)
if result:
print(result)