re = /^\/\/.*(*SKIP)(*FAIL)|("[^"]+")/m
str = '// eehen nhdhdhd ooe "jjejej" ejeje "keihjen" jehhemm
jejej "jejeooe" kekek "jilnana" jennbeb'
subst = '<span class="red">$1</span>'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result