package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)Hello my name is john, and I like pizza(*SKIP)(*F)|Hello my name is [^,]+, and I like pizza`)
var str = `Heloo my name is abcd, and I like pizza
Hello my name is asdf, and I like pizza
Hello my name is john, and I like pizza`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}