import re
regex = re.compile(r"Hello my name is john, and I like pizza(*SKIP)(*F)|Hello my name is [^,]+, and I like pizza", flags=re.MULTILINE)
test_str = ("Heloo my name is abcd, and I like pizza\n"
"Hello my name is asdf, and I like pizza\n"
"Hello my name is john, and I like pizza")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")