# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/<img(.*?)src="(.*?)"(.*?)\\/>/<img$1src="NEW VALUE"$3\/>/gmi;t' <<< "<img widht=\"200px\" height=\"200px\" src=\"http://imagesite.com/test.png\"/>"