use strict;
my $str = '<img widht="200px" height="200px" src="http://imagesite.com/test.png"/>';
my $regex = qr/<img(.*?)src="(.*?)"(.*?)\/>/mip;
my $subst = '<img$1src="NEW VALUE"$3/>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";