import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<img(.*?)src=\"(.*?)\"(.*?)\\/>";
final String string = "<img widht=\"200px\" height=\"200px\" src=\"http://imagesite.com/test.png\"/>";
final String subst = "<img$1src=\"NEW VALUE\"$3/>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}