using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<img(.*?)src=""(.*?)""(.*?)\/>";
string substitution = @"<img$1src=""NEW VALUE""$3/>";
string input = @"<img widht=""200px"" height=""200px"" src=""http://imagesite.com/test.png""/>";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}