const regex = /<img(.*?)src="(.*?)"(.*?)\/>/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<img(.*?)src="(.*?)"(.*?)\\\/>', 'gmi')
const str = `<img widht="200px" height="200px" src="http://imagesite.com/test.png"/>`;
const subst = `<img$1src="NEW VALUE"$3/>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);