$re = '/<img(.*?)src="(.*?)"(.*?)\/>/mi';
$str = '<img widht="200px" height="200px" src="http://imagesite.com/test.png"/>';
$subst = "<img$1src=\"NEW VALUE\"$3/>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;