// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?mi)<img(.*?)src="(.*?)"(.*?)\/>"#).unwrap();
let string = "<img widht=\"200px\" height=\"200px\" src=\"http://imagesite.com/test.png\"/>";
let substitution = "<img$1src=\"NEW VALUE\"$3/>";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}