import Foundation
let pattern = #"<img(.*?)src="(.*?)"(.*?)\/>"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"<img widht="200px" height="200px" src="http://imagesite.com/test.png"/>"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"<img$1src="NEW VALUE"$3/>"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)