using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?s)<(t[hd])[^>]*?>.*?<\/\1>(*SKIP)(*FAIL)|\n";
string substitution = @"";
string input = @"<table>
<tr><th>HEader 1</th><th> header
2</th>
</tr>
<tr><td width=""100""><b>cell
content</b></td><td>cell 2</td></tr>
</table>";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}