const regex = /(?s)<(t[hd])[^>]*?>.*?<\/\1>(*SKIP)(*FAIL)|\n/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?s)<(t[hd])[^>]*?>.*?<\\\/\\1>(*SKIP)(*FAIL)|\\n', 'g')
const str = `<table>
<tr><th>HEader 1</th><th> header
2</th>
</tr>
<tr><td width="100"><b>cell
content</b></td><td>cell 2</td></tr>
</table>`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);