$re = '/(?s)<(t[hd])[^>]*?>.*?<\/\1>(*SKIP)(*FAIL)|\n/';
$str = '<table>
<tr><th>HEader 1</th><th> header
2</th>
</tr>
<tr><td width="100"><b>cell
content</b></td><td>cell 2</td></tr>
</table>';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;