use strict;
my $str = '<table>
<tr><th>HEader 1</th><th> header
2</th>
</tr>
<tr><td width="100"><b>cell
content</b></td><td>cell 2</td></tr>
</table>';
my $regex = qr/(?s)<(t[hd])[^>]*?>.*?<\/\1>(*SKIP)(*FAIL)|\n/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";