re = /(?s)<(t[hd])[^>]*?>.*?<\/\1>(*SKIP)(*FAIL)|\n/
str = '<table>
<tr><th>HEader 1</th><th> header
2</th>
</tr>
<tr><td width="100"><b>cell
content</b></td><td>cell 2</td></tr>
</table>'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result