using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:10|127|172\.(?:1[6-9]|2[0-9]|3[01])|192\.168)\..*";
string input = @"1.2.3.4
192.168.10.20
10.20.30.40
172.10.20.30
172.17.100.200
127.0.0.1
100.200.300.400
1.192.168.200
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}