// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?:10|127|172\.(?:1[6-9]|2[0-9]|3[01])|192\.168)\..*").unwrap();
let string = "1.2.3.4
192.168.10.20
10.20.30.40
172.10.20.30
172.17.100.200
127.0.0.1
100.200.300.400
1.192.168.200
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}