const regex = /^(?:10|127|172\.(?:1[6-9]|2[0-9]|3[01])|192\.168)\..*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:10|127|172\\.(?:1[6-9]|2[0-9]|3[01])|192\\.168)\\..*', 'gm')
const str = `1.2.3.4
192.168.10.20
10.20.30.40
172.10.20.30
172.17.100.200
127.0.0.1
100.200.300.400
1.192.168.200
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}