using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"https?://(.*\.toledano\.org)(:[0-9]+)?";
string substitution = @"";
string input = @"https://media.toledano.org/assets/js/disqus-v1.0.10.html";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}