$re = '/https?://(.*\.toledano\.org)(:[0-9]+)?/';
$str = 'https://media.toledano.org/assets/js/disqus-v1.0.10.html';
$subst = "";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;