import re
regex = re.compile(r"https?://(.*\.toledano\.org)(:[0-9]+)?")
test_str = "https://media.toledano.org/assets/js/disqus-v1.0.10.html"
subst = ""
result = regex.sub(subst, test_str, count=1)
if result:
print(result)