package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`https?://(.*\.toledano\.org)(:[0-9]+)?`)
var str = []byte(`https://media.toledano.org/assets/js/disqus-v1.0.10.html`)
var substitution = []byte("")
var count = 1 // negative counter is equivalent to global case (replace all)
str = re.ReplaceAllStringFunc(str, func(s string) string {
if count == 0 {
return s
}
count -= 1
return re.ReplaceAllString(s, substitution)
})
fmt.Println(string(str))
}