// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"https?://(.*\.toledano\.org)(:[0-9]+)?").unwrap();
let string = "https://media.toledano.org/assets/js/disqus-v1.0.10.html";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace(string, substitution);
println!("{}", result);
}