use strict;
my $str = 'https://media.toledano.org/assets/js/disqus-v1.0.10.html';
my $regex = qr/https?://(.*\.toledano\.org)(:[0-9]+)?/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";