const regex = new RegExp('https?://(.*\\.toledano\\.org)(:[0-9]+)?', '')
const str = `https://media.toledano.org/assets/js/disqus-v1.0.10.html`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);