using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([a-zA-Z0-9\-_\.]+):([0-9]{1,5})";
string input = @"127.0.0.1:45681
56.22.67.11:14
lombao.net:543
proxis semaforos.ly:326";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}