re = /([a-zA-Z0-9\-_\.]+):([0-9]{1,5})/m
str = '127.0.0.1:45681
56.22.67.11:14
lombao.net:543
proxis semaforos.ly:326'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end