const regex = /([a-zA-Z0-9\-_\.]+):([0-9]{1,5})/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([a-zA-Z0-9\\-_\\.]+):([0-9]{1,5})', 'gm')
const str = `127.0.0.1:45681
56.22.67.11:14
lombao.net:543
proxis semaforos.ly:326`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}