import re
regex = re.compile(r"([a-zA-Z0-9\-_\.]+):([0-9]{1,5})", flags=re.MULTILINE)
test_str = ("127.0.0.1:45681\n"
"56.22.67.11:14\n"
"lombao.net:543\n"
"proxis semaforos.ly:326")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")