use strict;
my $str = '127.0.0.1:45681
56.22.67.11:14
lombao.net:543
proxis semaforos.ly:326';
my $regex = qr/([a-zA-Z0-9\-_\.]+):([0-9]{1,5})/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}