$re = '/([a-zA-Z0-9\-_\.]+):([0-9]{1,5})/m';
$str = '127.0.0.1:45681
56.22.67.11:14
lombao.net:543
proxis semaforos.ly:326';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);