// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)([a-zA-Z0-9\-_\.]+):([0-9]{1,5})").unwrap();
let string = "127.0.0.1:45681
56.22.67.11:14
lombao.net:543
proxis semaforos.ly:326";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}