# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(href=")(\\/[^"]*?\\/)([^\\/]*\.[^"]+)/\1\/sites\/default\/files\/resources\/\3/g;t' <<< "<a href=\"/app/webroot/files/file/Edital%20143-2011.pdf\">
<a target=\"_blank\" href=\"http://www.ipea.gov.br/code/chamada2011\">
"