import re
regex = re.compile(r"(href=\")(\/[^\"]*?\/)([^\/]*\.[^\"]+)")
test_str = ("<a href=\"/app/webroot/files/file/Edital%20143-2011.pdf\">\n"
"<a target=\"_blank\" href=\"http://www.ipea.gov.br/code/chamada2011\">\n\n")
subst = "\\1/sites/default/files/resources/\\3"
result = regex.sub(subst, test_str)
if result:
print(result)