$re = '/(href=")(\/[^"]*?\/)([^\/]*\.[^"]+)/';
$str = '<a href="/app/webroot/files/file/Edital%20143-2011.pdf">
<a target="_blank" href="http://www.ipea.gov.br/code/chamada2011">
';
$subst = "\1/sites/default/files/resources/\3";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;