// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(href=")(\/[^"]*?\/)([^\/]*\.[^"]+)"#).unwrap();
let string = "<a href=\"/app/webroot/files/file/Edital%20143-2011.pdf\">
<a target=\"_blank\" href=\"http://www.ipea.gov.br/code/chamada2011\">
";
let substitution = "\\1/sites/default/files/resources/\\3";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}