import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(href=\")(\\/[^\"]*?\\/)([^\\/]*\\.[^\"]+)";
final String string = "<a href=\"/app/webroot/files/file/Edital%20143-2011.pdf\">\n"
+ "<a target=\"_blank\" href=\"http://www.ipea.gov.br/code/chamada2011\">\n\n";
final String subst = "\\1/sites/default/files/resources/\\3";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}