const regex = /(href=")(\/[^"]*?\/)([^\/]*\.[^"]+)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(href=")(\\\/[^"]*?\\\/)([^\\\/]*\\.[^"]+)', 'g')
const str = `<a href="/app/webroot/files/file/Edital%20143-2011.pdf">
<a target="_blank" href="http://www.ipea.gov.br/code/chamada2011">
`;
const subst = `\1/sites/default/files/resources/\3`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);