using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"=(?=[\w'-])|(?<=[\w'-])=";
string substitution = @"s";
string input = @"I've got a many web APP=. My app= is not working fast. It'= slow app=
";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}