use strict;
my $str = 'I\'ve got a many web APP=. My app= is not working fast. It\'= slow app=
';
my $regex = qr/=(?=[\w'-])|(?<=[\w'-])=/p;
my $subst = 's';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";