const regex = /=(?=[\w'-])|(?<=[\w'-])=/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('=(?=[\\w\'-])|(?<=[\\w\'-])=', 'g')
const str = `I've got a many web APP=. My app= is not working fast. It'= slow app=
`;
const subst = `s`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);