re = /=(?=[\w'-])|(?<=[\w'-])=/
str = 'I\'ve got a many web APP=. My app= is not working fast. It\'= slow app=
'
subst = 's'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result