$re = '/=(?=[\w\'-])|(?<=[\w\'-])=/';
$str = 'I\'ve got a many web APP=. My app= is not working fast. It\'= slow app=
';
$subst = "s";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;