import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "=(?=[\\w'-])|(?<=[\\w'-])=";
final String string = "I've got a many web APP=. My app= is not working fast. It'= slow app=\n\n";
final String subst = "s";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}