#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?is)(?:<option)([^>]*)( value="[^"]*")([^>]*\>|\>)([^>]*)(?:<)"
Local $sString = "<select id="OptionToChoose">" & @CRLF & _
" <option value="" selected="selected">Choose option</option>" & @CRLF & _
" <option></option>" & @CRLF & _
" <option value="1" class="1">Sun</option>" & @CRLF & _
" <option class="2" value="2">Earth</option>" & @CRLF & _
" <option class="3" selected="selected" value="3" color="blue">Moon</option>" & @CRLF & _
"</select>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")