// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)(?is)(?:<option)([^>]*)( value="[^"]*")([^>]*\>|\>)([^>]*)(?:<)"#).unwrap();
let string = "<select id=\"OptionToChoose\">
<option value=\"\" selected=\"selected\">Choose option</option>
<option></option>
<option value=\"1\" class=\"1\">Sun</option>
<option class=\"2\" value=\"2\">Earth</option>
<option class=\"3\" selected=\"selected\" value=\"3\" color=\"blue\">Moon</option>
</select>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}